Tutorial DNSCrypt Untuk Windows

ISP di Indonesia sedang marak menggerakkan kegiatan pemblokiran konten / censorship internet, dengan tujuan mencegah penyebaran konten ilegal, pornografi, SARA, dan sebagainya. Tujuan ini memang mulia, akan tetapi kadang berimbas pada pemblokiran beberapa web yang mungkin “tidak bersalah”, seperti Vimeo. Saya pribadi sering mengunduh video-video indie  yang menarik di web tersebut. Sayangnya, sensor dilakukan semakin ketat, dan cara-cara lama tidak lagi dapat dipakai.

Cara lama untuk melewati sensor adalah dengan menggunakan DNS yang tidak menggunakan sensor atau content filtering, seperti dengan menggunakan DNS milik google (8.8.8.8 dan 8.8.4.4).

Klien -> DNS alternatif 8.8.8.8 / 8.8.4.4 port 53 -> browsing tanpa sensor

Akan tetapi, trik mengganti DNS sudah mulai  tidak dapat digunakan semenjak ISP melakukan intersepsi nameserver lookup / query.

Klien -> DNS alternatif 8.8.8.8 / 8.8.4.4 port 53 -> Intersepsi port 53 ke server DNS ISP -> browsing dengan sensor

Cara lama yang kedua adalah menggunakan VPN. Cara ini masih bisa menembus sensor internet yang dilakukan oleh ISP, namun sayangnya tidak semua pengguna internet (terutama bagi yang masih awam internet) bisa menggunakan VPN dengan baik dan benar.

Selain itu, VPN dengan koneksi yang cepat biasanya adalah VPN premium. Dengan kata lain, untuk dapat merambah internet dengan kecepatan yang maksimal, sobat harus mengeluarkan uang ekstra untuk menyewa VPN premium tersebut.

Nah, untuk itu dalam tutorial kali ini, saya mencoba untuk mengangkat tema “Tutorial DNScrypt untuk windows”.

Apa itu DNSCrypt?

DNSCrypt adalah software kecil yang berfungsi untuk meng-enkripsi trafik / lalu lintas data DNS antara user dengan server DNS secara terenkripsi. Karena sifatnya yang ter-enkripsi maka trafik DNS akan sulit terlacak atau di deteksi.

Logika jika kita menggunakan DNSCrypt adalah sebagai berikut :

Klien -> DNS resolver lokal + DNSCrypt (terenkripsi) -> browsing tanpa sensor

Cara penggunaan / cara instalasi DNSCrypt untuk Windows

Cara menginstal DNSCrypt untuk Windows sangat mudah, silakan ikuti langkah-langkahnya disini :

  • Pastikan .Net Framework sudah terinstal di pc sobat. Jika belum terinstal, silakan instal dan unduh dari sini
  • Unduh DNSCrypt yang sudah saya bundel menjadi satu disini (ukuran file : 380 kb)
  • Selanjutnya, ekstrak file yang sobat download tadi menggunakan software pengarsip kesayangan sobat (winrar, winzip, dsb)
  • Setelah sukses di ekstrak, akan terdapat sebuah folder baru dengan nama “dnscrypt”

Selanjutnya, untuk menjalankan DNSCrypt cukup klik 2 kali pada file “dnscrypt-winclient.exe”

Tutorial pengaturan DNSCrypt

Setelah sobat menjalankan file “dnscrypt-winclient.exe” dan interface software nya sudah terbuka, klik pada tab “NIC’s”, kemudian tandai pada “MS TCP Loopback interface”.

Tutorial DNSCrypt Untuk Windows - Setting NICs
Tutorial DNSCrypt Untuk Windows – Setting NICs

Setelah itu, klik pada tab “Config”, pilih server DNS yang akan digunakan pada opsi “Select provider” (saya merekomendasikan server Singapore karena lokasinya dekat Indonesia). Kemudian, klik pada tombol “Start”.

Tutorial DNSCrypt Untuk Windows - Pilih DNS provider
Tutorial DNSCrypt Untuk Windows – Pilih DNS provider

Jika tombol start di klik, maka akan muncul sebuah jendela Windows baru dengan posisi ter-minimize. Klik windows tersebut, agar sobat dapat memonitor koneksi DNSCrypt. Jika nampak seperti gambar berikut ini, maka sobat bisa menggunakan DNS dengan IP address 127.0.0.1

Tutorial DNSCrypt Untuk Windows - Koneksi DNSCrypt
Tutorial DNSCrypt Untuk Windows – Koneksi DNSCrypt

Jika sobat me-minimize DNSCrypt proxy client, maka DNSCrypt akan terminimize ke system tray, jadi sobat bisa lebih leluasa untuk menggunakan Windows untuk aktifitas yang lain.

Mengetes koneksi DNSCrypt

Untuk mengetes apakah DNSCrypt berjalan dengan baik, silakan ketikkan perintah berikut lewat CMD “nslookup www.fazar.net 127.0.0.1” (tanpa tanda kutip), dan jika hasilnya seperti ini, maka DNSCrypt siap untuk digunakan.

C:\Documents and Settings\My PC>nslookup www.fazar.net 127.0.0.1
Server:  localhost
Address:  127.0.0.1

Non-authoritative answer:
Name:    fazar.net
Address:  31.***.**.**
Aliases:  www.fazar.net

Selanjutnya, tinggal ganti DNS sobat agar menggunakan 127.0.0.1 sebagai primary DNS di pengaturan TCP/IP interface jaringan. Untuk secondary DNS, silakan di kosongkan saja.

Tutorial DNSCrypt Untuk Windows – Setting DNS lokal
Tutorial DNSCrypt Untuk Windows – Setting DNS lokal

Semoga “tutorial DNSCrypt untuk Windows” ini bisa bermanfaat untuk sobat. Jika tutorial DNSCrypt untuk Windows ini bermanfaat, jangan lupa share dan like dengan meng-klik icon Facebook/Twitter/Google+ yang ada di halaman ini.

Peringatan

Saya pribadi sangat mendukung usaha pemerintah kita dalam memerangi permasalahan yang berhubungan dengan konten ilegal, pornografi, malware dan sebagainya. Oleh karena itu, mari kita gunakan tutorial DNSCrypt untuk Windows ini untuk tujuan yang positif.

Jadilah user internet yang cerdas dan bermartabat. :)

31 pemikiran pada “Tutorial DNSCrypt Untuk Windows”

  1. Makasih om tutorialnya. Ane make server Canberra malah lebih cepet haha dari yg SG, kagak tau napa. Ada apa ini ya? Apa Indo makin merapat ke Australia daripada Tiongkok? *konspirasi bego*

    Balas
    • belum ada dnscrypt di mikrotik. kalau pun memang ingin benar-benar ingin pake dnscrypt, terpaksa harus set 1 server lagi untuk jalanin dnscrypt-nya. btw, untuk bypass filtering, untuk mikrotik bisa pake dns punya opendns.

      /ip firewall nat
      add action=dst-nat chain=dstnat comment="Intercept DNS" dst-port=53 protocol=udp to-addresses=208.67.222.222 to-ports=5353

      Balas
    • kalo nggak ada loopback interface, juga bisa pake interface lain yg terdeteksi. untuk setting dns tetap diarahkan ke 127.0.0.1

      Balas
  2. muantep mas…
    kini ane bisa akses situs thepiratebay.se again \^_^/ mo update koleksi box office lg.. horee… Hatur Thank You Mas Bro..

    Balas
  3. mas aku mau nanya, apakah dnscrypt itu bisa diterapkan di warnet yang aku punya?….
    sudah di coba install dnscrypt nya di server tapi ane coba buka web yg diblokir lewat komputer client masih tetep internet positif….. apakah di komp client jg harus di instal dnscrypt nya jg? tolong mas pencerahannya hatur nuhun….

    Balas
    • warnetnya pake mikrotik nggak? kalo iya, coba pake script ini

      /ip firewall nat
      add action=dst-nat chain=dstnat comment="DNS Intercept" dst-port=53 protocol=udp to-addresses=128.199.248.105 to-ports=5353

      Balas
    • install di pc server, trus cek list kartu lan nya di bagian “NIC’s” dan “act as a gateway device”. set PC klien untuk pake DNS dengan IP server, misalnya 192.168.1.1

      Balas
  4. Saya bisa maen TalonRO lagi bang.
    TENGKYU!!!!

    Ini negeri ga isa bedain situs gelap ama situs game.

    Goblog pisan.

    Balas
  5. Mas mau tanya, untuk CPU di Kantor saya Jaringan Internet di Komputer akan Terputus Jika VPN saya Tersambung, di Test di Ping Cmd jalan Normal namun di coba untuk membuka Situs Internet mati penjelasan Windows Tidak merespon, untuk Browsing ke Luar Vpnnya harus diputus terlebih dahulu, kebetulan di kantor menggunakan Aplikasi Vpn Resmi bukan lewat VPN melalui Browsing
    bagaimana untuki mengatasi hal ini? agar VPN tetap tersambung dan jaringan koneksi intenetnya juga tetap bisa jalan
    Tks….

    Balas
    • iya mas.. harus di switch dulu kalo mas punya multiple connection atau koneksi lebih dari satu. nggak bisa jalan vpn dan koneksi biasa secara bersamaan. contoh yg sering pake vpn biasanya perusahaan kargo, travel, dan sebagainya.

      Balas

Tinggalkan komentar